[Zambia] Character issues in Zambia

Henry Balen balen at acm.org
Mon Jun 15 15:36:24 PDT 2009


Well I fixed the problem. It was one of my own making ... all I needed  
to do was specify the character encoding in the XHTML returned by the  
AJAX calls to be explicitly latin1.
Code is deployed and in SVN. Sorry about that.

Henry

On Jun 15, 2009, at 18:13, Henry Balen wrote:

>
> Renée pointed out one of the character issues. In some of the  
> programme titles (and bios) people have used different single quote  
> characters (instead of the plain quote ' ). This could arise if  
> folks have cut and paste from word or another editor, or just use  
> characters such as `.
>
> I see in view such as ViewAllSessions.php you use htmlspecialchars()  
> to get round this. However, that is not compatible with  
> htmlentities() which we use elsewhere. While htmlspecialchars()  
> catches the quote issue etc. it interferes with the accents that   
> htmlspecialchars() deals with.
> Still looking for a solution...
>
> Henry
>
> On Jun 15, 2009, at 17:52, Henry Balen wrote:
>
>> Peter,
>>
>> I have added a tab to the view participants page so that we can see  
>> a list of what sessions a participant has been assigned to. This  
>> can help when we weed out dups.
>> As a test I went to http://scheduling.anticipationsf.ca/ViewParticipantDetails.php 
>>  and looked at the details for Von (Vonarburg). One of the session  
>> titles appears to have a character that the html_entities did not  
>> encode or something else is going on. If you select the row with  
>> Zambia id of 2001 the tabs will fill, then select the sessions tab  
>> to see the issue.
>>
>> Since the session titles are entered via Zambia and not directly  
>> into the DB I would have thought that they would be consistent. Any  
>> ideas?
>>
>> Henry
>>
>




More information about the Zambia-list mailing list